Rancher doesn't properly sanitize credentials in cluster template answers
CVE-2021-36783GHSA-8w87-58w6-hfv8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/rancher 2.6.4, 2.5.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.5.0, <= 2.5.12>= 2.6.0, <= 2.6.3
- Fixed in
- 2.5.13, 2.6.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8w87-58w6-hfv8 lists affected ranges: Go github.com/rancher/rancher >=2.5.0 =2.6.0 <=2.6.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2021-36783: 0.80% estimated exploitation activity in the next 30 days; percentile 56.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact It was discovered that in Rancher versions up to and including 2.5.12 and 2.6.3 there is a failure to properly sanitize credentials in cluster template answers. This failure can lead to plaintext storage and exposure of credentials, passwords and API tokens. The exposed credentials are visible in Rancher to authenticated Cluster Owners, Cluster Members, Project Owners and Project Members on the endpoints /v1/management.cattle.io.clusters, /v3/clusters and /k8s/clusters/local/apis/management.cattle.io/v3/clusters. Sensitive fields are now stripped from Clusters objects before the object is stored. For objects that existed before this security fix, a one-time migration happens on startup. Important: - It is highly advised to review for potential leaked credentials in this scenario, and to change them if deemed necessary. - The final impact severity for confidentiality, integrity and availability is dependent on the permissions that the leaked credentials have on their own…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8w87-58w6-hfv8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-36783 Advisory: Rancher doesn't properly sanitize credentials in cluster template answers IDs: CVE-2021-36783, GHSA-8w87-58w6-hfv8 Record: https://patchnext.com/advisories/cve-2021-36783 (revision 1, source checked 26 Oct 2026, 15:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/rancher 2.6.4, 2.5.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rancher/rancher: affected >= 2.5.0, <= 2.5.12; >= 2.6.0, <= 2.6.3; fixed in 2.5.13, 2.6.4 ## Suggested inspection (read-only) - Go github.com/rancher/rancher: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rancher/rancher. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8w87-58w6-hfv8 (GitHub-reviewed advisory GHSA-8w87-58w6-hfv8 lists affected ranges: Go github.com/rancher/rancher >=2.5.0 =2.6.0 <=2.6.3) Commands are suggestions: review each one before running it.
Loading voting…