Druid ingestion system Authenticated users can read data from other sources than intended
CVE-2021-36749GHSA-9p5g-vg43-mj5r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.druid:druid-core 0.22.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.druid:druid-core
- Affected
- < 0.22.0
- Fixed in
- 0.22.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9p5g-vg43-mj5r lists affected ranges: Maven org.apache.druid:druid-core >=0 <0.22.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2021-36749: 80.91% estimated exploitation activity in the next 30 days; percentile 99.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In the Druid ingestion system, the InputSource is used for reading data from a certain data source. However, the HTTP InputSource allows authenticated users to read data from other sources than intended, such as the local file system, with the privileges of the Druid server process. This is not an elevation of privilege when users access Druid directly, since Druid also provides the Local InputSource, which allows the same level of access. But it is problematic when users interact with Druid indirectly through an application that allows users to specify the HTTP InputSource, but not the Local InputSource. In this case, users could bypass the application-level restriction by passing a file URL to the HTTP InputSource. This issue was previously mentioned as being fixed in 0.21.0 as per CVE-2021-26920 but was not fixed in 0.21.0 or 0.21.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9p5g-vg43-mj5r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-36749 Advisory: Druid ingestion system Authenticated users can read data from other sources than intended IDs: CVE-2021-36749, GHSA-9p5g-vg43-mj5r Record: https://patchnext.com/advisories/cve-2021-36749 (revision 1, source checked 26 Oct 2026, 16:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.druid:druid-core 0.22.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.druid:druid-core: affected < 0.22.0; fixed in 0.22.0 ## Suggested inspection (read-only) - Maven org.apache.druid:druid-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.druid:druid-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9p5g-vg43-mj5r (GitHub-reviewed advisory GHSA-9p5g-vg43-mj5r lists affected ranges: Maven org.apache.druid:druid-core >=0 <0.22.0) Commands are suggestions: review each one before running it.
Loading voting…