Skip to content

← Actionable
Medium, CVSS 6.1amended

Open redirect in url-parse

CVE-2021-3664GHSA-hh27-ffr2-f2jc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (url-parse 1.5.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm url-parse

    Affected
    >= 0.1.0, < 1.5.2
    Fixed in
    1.5.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2021-3664: 2.12% estimated exploitation activity in the next 30 days; percentile 81.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview Affected versions of npm url-parse are vulnerable to URL Redirection to Untrusted Site. Impact Depending on library usage and attacker intent, impacts may include allow/block list bypasses, SSRF attacks, open redirects, or other undesired behavior.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hh27-ffr2-f2jc

  2. Revision 1 · created ·

    Published from osv record GHSA-hh27-ffr2-f2jc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-3664

Advisory: Open redirect in url-parse
IDs: CVE-2021-3664, GHSA-hh27-ffr2-f2jc
Record: https://patchnext.com/advisories/cve-2021-3664 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: url-parse 1.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm url-parse: affected >= 0.1.0, < 1.5.2; fixed in 1.5.2

## Suggested inspection (read-only)
- `npm ls url-parse --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on url-parse.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hh27-ffr2-f2jc (OSV record GHSA-hh27-ffr2-f2jc lists affected ranges: npm url-parse >=0.1.0 <1.5.2 (fixed))
- Verified: https://github.com/advisories/GHSA-hh27-ffr2-f2jc (GitHub-reviewed advisory GHSA-hh27-ffr2-f2jc lists affected ranges: npm url-parse >=0.1.0 <1.5.2)

Commands are suggestions: review each one before running it.

Loading voting…