Moodle Cross-site Scripting vulnerability
CVE-2021-36568GHSA-fm6m-fg23-67jq
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- <= 3.9.7>= 3.10.0, <= 3.10.4>= 3.11.0, < 3.11.10
- Fixed in
- 3.11.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fm6m-fg23-67jq lists affected ranges: Packagist moodle/moodle >=0 =3.10.0 =3.11.0 <3.11.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-36568: 1.04% estimated exploitation activity in the next 30 days; percentile 64.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In certain Moodle products after creating a course, it is possible to add in a arbitrary "Topic" a resource, in this case a "Database" with the type "Text" where its values "Field name" and "Field description" are vulnerable to Cross Site Scripting Stored(XSS). This affects Moodle 3.11.x prior to 3.11.10, Moodle 3.10.4, and Moodle 3.9.7.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fm6m-fg23-67jq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-36568 Advisory: Moodle Cross-site Scripting vulnerability IDs: CVE-2021-36568, GHSA-fm6m-fg23-67jq Record: https://patchnext.com/advisories/cve-2021-36568 (revision 1, source checked 26 Oct 2026, 14:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: moodle/moodle 3.11.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected <= 3.9.7; >= 3.10.0, <= 3.10.4; >= 3.11.0, < 3.11.10; fixed in 3.11.10 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fm6m-fg23-67jq (GitHub-reviewed advisory GHSA-fm6m-fg23-67jq lists affected ranges: Packagist moodle/moodle >=0 =3.10.0 =3.11.0 <3.11.10) Commands are suggestions: review each one before running it.
Loading voting…