Skip to content

← Actionable
High, CVSS 7.8

Relative Path Traversal in git-delta

CVE-2021-36376GHSA-5xg3-j2j6-rcx4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (git-delta 0.8.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io git-delta

    Affected
    < 0.8.3
    Fixed in
    0.8.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-36376: 0.42% estimated exploitation activity in the next 30 days; percentile 36.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

git-delta before 0.8.3 on Windows resolves an executable's pathname as a relative path from the current directory.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5xg3-j2j6-rcx4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-36376

Advisory: Relative Path Traversal in git-delta
IDs: CVE-2021-36376, GHSA-5xg3-j2j6-rcx4
Record: https://patchnext.com/advisories/cve-2021-36376 (revision 1, source checked 26 Oct 2026, 15:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: git-delta 0.8.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io git-delta: affected < 0.8.3; fixed in 0.8.3

## Suggested inspection (read-only)
- crates.io git-delta: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on git-delta.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5xg3-j2j6-rcx4 (GitHub-reviewed advisory GHSA-5xg3-j2j6-rcx4 lists affected ranges: crates.io git-delta >=0 <0.8.3)

Commands are suggestions: review each one before running it.

Loading voting…