Remote Code Execution in Apache Dubbo
CVE-2021-36161GHSA-qvm7-23cj-437v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.dubbo:dubbo 2.7.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.dubbo:dubbo
- Affected
- < 2.7.13
- Fixed in
- 2.7.13
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qvm7-23cj-437v lists affected ranges: Maven org.apache.dubbo:dubbo >=0 <2.7.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-36161: 2.47% estimated exploitation activity in the next 30 days; percentile 84.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Some component in Dubbo will try to print the formated string of the input arguments, which will possibly cause RCE for a maliciously customized bean with special toString method. In the latest version, we fix the toString call in timeout, cache and some other places. Fixed in Apache Dubbo 2.7.13
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qvm7-23cj-437v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-36161 Advisory: Remote Code Execution in Apache Dubbo IDs: CVE-2021-36161, GHSA-qvm7-23cj-437v Record: https://patchnext.com/advisories/cve-2021-36161 (revision 1, source checked 26 Oct 2026, 16:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.dubbo:dubbo 2.7.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.dubbo:dubbo: affected < 2.7.13; fixed in 2.7.13 ## Suggested inspection (read-only) - Maven org.apache.dubbo:dubbo: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.dubbo:dubbo. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qvm7-23cj-437v (GitHub-reviewed advisory GHSA-qvm7-23cj-437v lists affected ranges: Maven org.apache.dubbo:dubbo >=0 <2.7.13) Commands are suggestions: review each one before running it.
Loading voting…