Cross-site Scripting in SilverStripe Framework
CVE-2021-36150GHSA-j66h-cc96-c32q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/admin 1.8.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist silverstripe/admin
- Affected
- >= 1.0.0, < 1.8.1
- Fixed in
- 1.8.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j66h-cc96-c32q lists affected ranges: Packagist silverstripe/admin >=1.0.0 <1.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-36150: 0.85% estimated exploitation activity in the next 30 days; percentile 58.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
SilverStripe Framework through 4.8.1 allows XSS.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j66h-cc96-c32q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-36150 Advisory: Cross-site Scripting in SilverStripe Framework IDs: CVE-2021-36150, GHSA-j66h-cc96-c32q Record: https://patchnext.com/advisories/cve-2021-36150 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: silverstripe/admin 1.8.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist silverstripe/admin: affected >= 1.0.0, < 1.8.1; fixed in 1.8.1 ## Suggested inspection (read-only) - Packagist silverstripe/admin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on silverstripe/admin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j66h-cc96-c32q (GitHub-reviewed advisory GHSA-j66h-cc96-c32q lists affected ranges: Packagist silverstripe/admin >=1.0.0 <1.8.1) Commands are suggestions: review each one before running it.
Loading voting…