Skip to content

← Actionable
High, CVSS 7.5

Magento affected by a server-side denial-of-service using a GraphQL field

CVE-2021-36044GHSA-wr57-3h2f-3q95

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist magento/project-community-edition

    Affected
    <= 2.0.2
    Fixed in
    no fixed version recorded
  • Packagist magento/community-edition

    Affected
    >= 2.4.2, <= 2.4.2>= 2.4.2-p1, < 2.4.2-p2>= 2.3.7, <= 2.3.7< 2.3.7-p1
    Fixed in
    2.3.7-p1, 2.4.2-p2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2021-36044: 2.01% estimated exploitation activity in the next 30 days; percentile 80.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability. An unauthenticated attacker could abuse this vulnerability to cause a server-side denial-of-service using a GraphQL field.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wr57-3h2f-3q95

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-36044

Advisory: Magento affected by a server-side denial-of-service using a GraphQL field
IDs: CVE-2021-36044, GHSA-wr57-3h2f-3q95
Record: https://patchnext.com/advisories/cve-2021-36044 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: magento/community-edition 2.4.2-p2, 2.3.7-p1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist magento/project-community-edition: affected <= 2.0.2
- Packagist magento/community-edition: affected >= 2.4.2, <= 2.4.2; >= 2.4.2-p1, < 2.4.2-p2; >= 2.3.7, <= 2.3.7; < 2.3.7-p1; fixed in 2.3.7-p1, 2.4.2-p2

## Suggested inspection (read-only)
- Packagist magento/project-community-edition: check the installed version with your package manager.
- Packagist magento/community-edition: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on magento/project-community-edition, magento/community-edition.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wr57-3h2f-3q95 (GitHub-reviewed advisory GHSA-wr57-3h2f-3q95 lists affected ranges: Packagist magento/project-community-edition >=0 =2.4.2 =2.4.2-p1 =2.3.7 =0 <2.3.7-p1)

Commands are suggestions: review each one before running it.

Loading voting…