Skip to content

← Actionable
High, CVSS 8.1

PHPMailer untrusted code may be run from an overridden address validator

CVE-2021-3603GHSA-77mr-wc79-m8j3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmailer/phpmailer 6.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-3603: 2.26% estimated exploitation activity in the next 30 days; percentile 83.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

If a function is defined that has the same name as the default built-in email address validation scheme (php), it will be called in default configuration as when no validation scheme is provided, the default scheme's callable php was being called. If an attacker is able to inject such a function into the application (a much bigger issue), it will be called whenever an email address is validated, such as when calling validateAddress(). Impact Low impact – exploitation requires that an attacker can already inject code into an application, but it provides a trigger pathway. Patches This is patched in PHPMailer 6.5.0 by denying the use of simple strings as validator function names, which is a very minor BC break. Workarounds Inject your own email validator function. References Reported by Vikrant Singh Chauhan via huntr.dev. CVE-2021-3603 For more information If you have any questions or comments about this advisory: Open an issue in the PHPMailer project Email us.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-77mr-wc79-m8j3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-3603

Advisory: PHPMailer untrusted code may be run from an overridden address validator
IDs: CVE-2021-3603, GHSA-77mr-wc79-m8j3
Record: https://patchnext.com/advisories/cve-2021-3603 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpmailer/phpmailer 6.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpmailer/phpmailer: affected < 6.5.0; fixed in 6.5.0

## Suggested inspection (read-only)
- Packagist phpmailer/phpmailer: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpmailer/phpmailer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-77mr-wc79-m8j3 (GitHub-reviewed advisory GHSA-77mr-wc79-m8j3 lists affected ranges: Packagist phpmailer/phpmailer >=0 <6.5.0)

Commands are suggestions: review each one before running it.

Loading voting…