Skip to content

← Actionable
Unrated

Magento stored cross-site scripting vulnerability

CVE-2021-36027GHSA-x2v2-2jhp-c5hv

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist magento/project-community-edition

    Affected
    <= 2.0.2
    Fixed in
    no fixed version recorded
  • Packagist magento/community-edition

    Affected
    < 2.3.7-p1>= 2.3.7, <= 2.3.7>= 2.4.2-p1, < 2.4.2-p2>= 2.4.2, <= 2.4.2
    Fixed in
    2.3.7-p1, 2.4.2-p2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2021-36027: 1.41% estimated exploitation activity in the next 30 days; percentile 72.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by a stored cross-site scripting vulnerability that could be abused by an attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x2v2-2jhp-c5hv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-36027

Advisory: Magento stored cross-site scripting vulnerability
IDs: CVE-2021-36027, GHSA-x2v2-2jhp-c5hv
Record: https://patchnext.com/advisories/cve-2021-36027 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: magento/community-edition 2.4.2-p2, 2.3.7-p1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist magento/project-community-edition: affected <= 2.0.2
- Packagist magento/community-edition: affected < 2.3.7-p1; >= 2.3.7, <= 2.3.7; >= 2.4.2-p1, < 2.4.2-p2; >= 2.4.2, <= 2.4.2; fixed in 2.3.7-p1, 2.4.2-p2

## Suggested inspection (read-only)
- Packagist magento/project-community-edition: check the installed version with your package manager.
- Packagist magento/community-edition: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on magento/project-community-edition, magento/community-edition.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x2v2-2jhp-c5hv (GitHub-reviewed advisory GHSA-x2v2-2jhp-c5hv lists affected ranges: Packagist magento/project-community-edition >=0 =0 =2.3.7 =2.4.2-p1 =2.4.2 <=2.4.2)

Commands are suggestions: review each one before running it.

Loading voting…