Cross site scripting via HTML attributes in the back end
CVE-2021-35955GHSA-hr3h-x6gq-rqcp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/contao 4.11.7, 4.9.18, 4.4.56; contao/core-bundle 4.11.7, 4.9.18, 4.4.56), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist contao/contao
- Affected
- >= 4.0.0, < 4.4.56>= 4.5.0, < 4.9.18>= 4.10.0, < 4.11.7
- Fixed in
- 4.11.7, 4.9.18, 4.4.56
Packagist contao/core-bundle
- Affected
- >= 4.0.0, < 4.4.56>= 4.5.0, < 4.9.18>= 4.10.0, < 4.11.7
- Fixed in
- 4.11.7, 4.9.18, 4.4.56
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hr3h-x6gq-rqcp lists affected ranges: Packagist contao/core-bundle >=4.0.0 =4.5.0 =4.10.0 =4.0.0 =4.5.0 =4.10.0 <4.11.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L
- EPSS
- CVE-2021-35955: 0.56% estimated exploitation activity in the next 30 days; percentile 46.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact It is possible for untrusted users to inject malicious code into HTML attributes in the back end, which will be executed both in the element preview (back end) and on the website (front end). Installations are only affected if there are untrusted back end users who have the rights to modify HTML fields (e.g. TinyMCE). Patches Update to Contao 4.4.56, 4.9.18 or 4.11.7 Workarounds Disable all fields that allow HTML for untrusted back end users or disable the login for these users. References https://contao.org/en/security-advisories/cross-site-scripting-via-html-attributes-in-the-back-end For more information If you have any questions or comments about this advisory, open an issue in contao/contao. Credits Thanks to Mikhail Khramenkov and Moritz Vondano for reporting this security issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hr3h-x6gq-rqcp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-35955 Advisory: Cross site scripting via HTML attributes in the back end IDs: CVE-2021-35955, GHSA-hr3h-x6gq-rqcp Record: https://patchnext.com/advisories/cve-2021-35955 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: contao/contao 4.11.7, 4.9.18, 4.4.56; contao/core-bundle 4.11.7, 4.9.18, 4.4.56. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist contao/contao: affected >= 4.0.0, < 4.4.56; >= 4.5.0, < 4.9.18; >= 4.10.0, < 4.11.7; fixed in 4.11.7, 4.9.18, 4.4.56 - Packagist contao/core-bundle: affected >= 4.0.0, < 4.4.56; >= 4.5.0, < 4.9.18; >= 4.10.0, < 4.11.7; fixed in 4.11.7, 4.9.18, 4.4.56 ## Suggested inspection (read-only) - Packagist contao/contao: check the installed version with your package manager. - Packagist contao/core-bundle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on contao/contao, contao/core-bundle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hr3h-x6gq-rqcp (GitHub-reviewed advisory GHSA-hr3h-x6gq-rqcp lists affected ranges: Packagist contao/core-bundle >=4.0.0 =4.5.0 =4.10.0 =4.0.0 =4.5.0 =4.10.0 <4.11.7) Commands are suggestions: review each one before running it.
Loading voting…