Skip to content

← Actionable
High, CVSS 8.6amended

Improper Input Validation and Command Injection in Ansible

CVE-2021-3583GHSA-2pfh-q76x-gwvm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ansible 2.11.2rc1, 2.10.11rc1, 2.9.23rc1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ansible

    Affected
    < 2.9.23rc1>= 2.10.0a1, < 2.10.11rc1>= 2.11.0a1, < 2.11.2rc1
    Fixed in
    2.9.23rc1, 2.11.2rc1, 2.10.11rc1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-3583: 0.90% estimated exploitation activity in the next 30 days; percentile 59.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in Ansible, where a user's controller is vulnerable to template injection. This issue can occur through facts used in the template if the user is trying to put templates in multi-line YAML strings and the facts being handled do not routinely include special template characters. This flaw allows attackers to perform command injection, which discloses sensitive information. The highest threat from this vulnerability is to confidentiality and integrity.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2pfh-q76x-gwvm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2pfh-q76x-gwvm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-3583

Advisory: Improper Input Validation and Command Injection in Ansible
IDs: CVE-2021-3583, GHSA-2pfh-q76x-gwvm
Record: https://patchnext.com/advisories/cve-2021-3583 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ansible 2.11.2rc1, 2.10.11rc1, 2.9.23rc1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ansible: affected < 2.9.23rc1; >= 2.10.0a1, < 2.10.11rc1; >= 2.11.0a1, < 2.11.2rc1; fixed in 2.9.23rc1, 2.11.2rc1, 2.10.11rc1

## Suggested inspection (read-only)
- `python -m pip show ansible`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ansible.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2pfh-q76x-gwvm (OSV record GHSA-2pfh-q76x-gwvm lists affected ranges: PyPI ansible >=0 =2.10.0a1 =2.11.0a1 <2.11.2rc1 (fixed))
- Verified: https://github.com/advisories/GHSA-2pfh-q76x-gwvm (GitHub-reviewed advisory GHSA-2pfh-q76x-gwvm lists affected ranges: PyPI ansible >=0 =2.10.0a1 =2.11.0a1 <2.11.2rc1)

Commands are suggestions: review each one before running it.

Loading voting…