Skip to content

← Actionable
High, CVSS 8.6

Nokogiri contains libxml Out-of-bounds Write vulnerability

CVE-2021-3517GHSA-jw9f-hh49-cvp9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nokogiri 1.11.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems nokogiri

    Affected
    < 1.11.4
    Fixed in
    1.11.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
EPSS
  • CVE-2021-3517: 16.99% estimated exploitation activity in the next 30 days; percentile 97.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There is a flaw in the xml entity encoding functionality of libxml2 in versions before 2.9.11. An attacker who is able to supply a crafted file to be processed by an application linked with the affected functionality of libxml2 could trigger an out-of-bounds read. The most likely impact of this flaw is to application availability, with some potential impact to confidentiality and integrity if an attacker is able to use memory information to further exploit the application. Nokogiri prior to version 1.11.4 used a vulnerable version of libxml2. Nokogiri 1.11.4 updated libxml2 to version 2.9.11 to address this and other vulnerabilities in libxml2.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jw9f-hh49-cvp9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-3517

Advisory: Nokogiri contains libxml Out-of-bounds Write vulnerability
IDs: CVE-2021-3517, GHSA-jw9f-hh49-cvp9
Record: https://patchnext.com/advisories/cve-2021-3517 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nokogiri 1.11.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems nokogiri: affected < 1.11.4; fixed in 1.11.4

## Suggested inspection (read-only)
- RubyGems nokogiri: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nokogiri.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jw9f-hh49-cvp9 (GitHub-reviewed advisory GHSA-jw9f-hh49-cvp9 lists affected ranges: RubyGems nokogiri >=0 <1.11.4)

Commands are suggestions: review each one before running it.

Loading voting…