Access control flaw in Kiali
CVE-2021-3495GHSA-mv55-23xp-3wp8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kiali/kiali 1.33.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.33.0
- Fixed in
- 1.33.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mv55-23xp-3wp8 lists affected ranges: Go github.com/kiali/kiali >=0 <1.33.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-3495: 0.97% estimated exploitation activity in the next 30 days; percentile 61.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An incorrect access control flaw was found in the kiali-operator in versions before 1.33.0. This flaw allows an attacker with a basic level of access to the cluster (to deploy a kiali operand) to use this vulnerability and deploy a given image to anywhere in the cluster, potentially gaining access to privileged service account tokens. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mv55-23xp-3wp8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-3495 Advisory: Access control flaw in Kiali IDs: CVE-2021-3495, GHSA-mv55-23xp-3wp8 Record: https://patchnext.com/advisories/cve-2021-3495 (revision 1, source checked 26 Oct 2026, 14:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kiali/kiali 1.33.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kiali/kiali: affected < 1.33.0; fixed in 1.33.0 ## Suggested inspection (read-only) - Go github.com/kiali/kiali: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kiali/kiali. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mv55-23xp-3wp8 (GitHub-reviewed advisory GHSA-mv55-23xp-3wp8 lists affected ranges: Go github.com/kiali/kiali >=0 <1.33.0) Commands are suggestions: review each one before running it.
Loading voting…