Remote Code Execution vulnerability in PHPMailer 6.4.1 running on Windows
CVE-2021-34551GHSA-7q44-r25x-wm4q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmailer/phpmailer 6.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmailer/phpmailer
- Affected
- < 6.5.0
- Fixed in
- 6.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7q44-r25x-wm4q lists affected ranges: Packagist phpmailer/phpmailer >=0 <6.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-34551: 2.80% estimated exploitation activity in the next 30 days; percentile 86.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
PHPMailer 6.4.1 contains a possible remote code execution vulnerability through the $langpath parameter of the setLanguage() method. If the $langpath parameter is passed unfiltered from user input, it can be set to a UNC path, and if an attacker is also able to create a remote mount on the server that the UNC path points to, a script file under their control may be executed. Impact Arbitrary code may be run by a remote attacker under the web server or PHP process running on Window hosts. Patches Mitigated in PHPMailer 6.5.0 by no longer treating translation files as PHP code, but by parsing their text content directly. This approach avoids the possibility of executing unknown code while retaining backward compatibility. This isn't ideal, so the current translation format is deprecated and will be replaced in the next major release. Workarounds Any of: Ensure that calling code does not pass unfiltered user-supplied data to the $langpath parameter of the setLanguage() method. Block or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7q44-r25x-wm4q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-34551 Advisory: Remote Code Execution vulnerability in PHPMailer 6.4.1 running on Windows IDs: CVE-2021-34551, GHSA-7q44-r25x-wm4q Record: https://patchnext.com/advisories/cve-2021-34551 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmailer/phpmailer 6.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmailer/phpmailer: affected < 6.5.0; fixed in 6.5.0 ## Suggested inspection (read-only) - Packagist phpmailer/phpmailer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmailer/phpmailer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7q44-r25x-wm4q (GitHub-reviewed advisory GHSA-7q44-r25x-wm4q lists affected ranges: Packagist phpmailer/phpmailer >=0 <6.5.0) Commands are suggestions: review each one before running it.
Loading voting…