Certificate check bypass in openssl-src
CVE-2021-3450GHSA-8hfj-xrj2-pm22
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 15.14.0, 14.16.1, 12.22.1, 10.24.1; openssl-src 111.15.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
runtime node
- Affected
- >= 10.0.0, < 10.24.1>= 12.0.0, < 12.22.1>= 14.0.0, < 14.16.1>= 15.0.0, < 15.14.0
- Fixed in
- 10.24.1, 15.14.0, 12.22.1, 14.16.1
crates.io openssl-src
- Affected
- >= 111.11.0, < 111.15.0
- Fixed in
- 111.15.0
Sources
- raw.githubusercontent.com runtime security intelligence
Node.js security working group core entry 76 lists CVE-2021-3450 affecting node >=10.0.0 =12.0.0 =14.0.0 =15.0.0 <15.14.0
VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.
- nodejs.org runtime security intelligence
The nodejs.org release index dates the first patched release for CVE-2021-3450 to 2021-04-06.
VerifiedObserved Official nodejs.org release index (dist/index.json).
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8hfj-xrj2-pm22 lists affected ranges: crates.io openssl-src >=111.11.0 <111.15.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2021-3450: 18.34% estimated exploitation activity in the next 30 days; percentile 97.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The X509VFLAGX509STRICT flag enables additional security checks of the certificates present in a certificate chain. It is not set by default. Starting from OpenSSL version 1.1.1h a check to disallow certificates in the chain that have explicitly encoded elliptic curve parameters was added as an additional strict check. An error in the implementation of this check meant that the result of a previous check to confirm that certificates in the chain are valid CA certificates was overwritten. This effectively bypasses the check that non-CA certificates must not be able to issue other certificates. If a "purpose" has been configured then there is a subsequent opportunity for checks that the certificate is a valid CA. All of the named "purpose" values implemented in libcrypto perform this check. Therefore, where a purpose is set the certificate chain will still be rejected even when the strict flag has been used. A purpose is set by default in libssl client and server certificate…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from vendor_advisory record nodejs-security-wg:core:76
- Revision 2 · published ·
Published from ghsa record GHSA-8hfj-xrj2-pm22
- Revision 1 · created ·
Created from vendor_advisory record nodejs-security-wg:core:76
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-3450 Advisory: Certificate check bypass in openssl-src IDs: CVE-2021-3450, GHSA-8hfj-xrj2-pm22 Record: https://patchnext.com/advisories/cve-2021-3450 (revision 3, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node 15.14.0, 14.16.1, 12.22.1, 10.24.1; openssl-src 111.15.0. A vendor fix does not mean a deployment is fixed. ## Affected components - runtime node: affected >= 10.0.0, < 10.24.1; >= 12.0.0, < 12.22.1; >= 14.0.0, < 14.16.1; >= 15.0.0, < 15.14.0; fixed in 10.24.1, 15.14.0, 12.22.1, 14.16.1 - crates.io openssl-src: affected >= 111.11.0, < 111.15.0; fixed in 111.15.0 ## Suggested inspection (read-only) - runtime node: check the installed version with your package manager. - crates.io openssl-src: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node, openssl-src. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/76.json (Node.js security working group core entry 76 lists CVE-2021-3450 affecting node >=10.0.0 =12.0.0 =14.0.0 =15.0.0 <15.14.0) - Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2021-3450 to 2021-04-06.) - Verified: https://github.com/advisories/GHSA-8hfj-xrj2-pm22 (GitHub-reviewed advisory GHSA-8hfj-xrj2-pm22 lists affected ranges: crates.io openssl-src >=111.11.0 <111.15.0) Commands are suggestions: review each one before running it.
Loading voting…