Remote code execution in Eclipse Theia
CVE-2021-34435GHSA-v9w2-v7j9-rjpr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@theia/mini-browser 1.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.3.9, < 1.9.0
- Fixed in
- 1.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v9w2-v7j9-rjpr lists affected ranges: npm @theia/mini-browser >=0.3.9 <1.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v9w2-v7j9-rjpr lists affected ranges: npm @theia/mini-browser >=0.3.9 <1.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-34435: 0.60% estimated exploitation activity in the next 30 days; percentile 48.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Eclipse Theia 0.3.9 to 1.8.1, the "mini-browser" extension allows a user to preview HTML files in an iframe inside the IDE. But with the way it is made it is possible for a previewed HTML file to trigger an RCE. This exploit only happens if a user previews a malicious file.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v9w2-v7j9-rjpr
- Revision 1 · created ·
Published from osv record GHSA-v9w2-v7j9-rjpr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-34435 Advisory: Remote code execution in Eclipse Theia IDs: CVE-2021-34435, GHSA-v9w2-v7j9-rjpr Record: https://patchnext.com/advisories/cve-2021-34435 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @theia/mini-browser 1.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @theia/mini-browser: affected >= 0.3.9, < 1.9.0; fixed in 1.9.0 ## Suggested inspection (read-only) - `npm ls @theia/mini-browser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @theia/mini-browser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v9w2-v7j9-rjpr (OSV record GHSA-v9w2-v7j9-rjpr lists affected ranges: npm @theia/mini-browser >=0.3.9 <1.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-v9w2-v7j9-rjpr (GitHub-reviewed advisory GHSA-v9w2-v7j9-rjpr lists affected ranges: npm @theia/mini-browser >=0.3.9 <1.9.0) Commands are suggestions: review each one before running it.
Loading voting…