XML External Entity (XXE) Injection in JDOM
CVE-2021-33813GHSA-2363-cqg2-863c
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jdom:jdom
- Affected
- <= 2.0.2
- Fixed in
- no fixed version recorded
Maven org.jdom:jdom2
- Affected
- < 2.0.6.1
- Fixed in
- 2.0.6.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2363-cqg2-863c lists affected ranges: Maven org.jdom:jdom2 >=0 =0 <=2.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-33813: 19.44% estimated exploitation activity in the next 30 days; percentile 97.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An XXE issue in SAXBuilder in JDOM through 2.0.6 allows attackers to cause a denial of service via a crafted HTTP request. As a workaround, to avoid external entities being expanded, one can call builder.setExpandEntities(false) and they won't be expanded.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2363-cqg2-863c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-33813 Advisory: XML External Entity (XXE) Injection in JDOM IDs: CVE-2021-33813, GHSA-2363-cqg2-863c Record: https://patchnext.com/advisories/cve-2021-33813 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.jdom:jdom2 2.0.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jdom:jdom: affected <= 2.0.2 - Maven org.jdom:jdom2: affected < 2.0.6.1; fixed in 2.0.6.1 ## Suggested inspection (read-only) - Maven org.jdom:jdom: check the installed version with your package manager. - Maven org.jdom:jdom2: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jdom:jdom, org.jdom:jdom2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2363-cqg2-863c (GitHub-reviewed advisory GHSA-2363-cqg2-863c lists affected ranges: Maven org.jdom:jdom2 >=0 =0 <=2.0.2) Commands are suggestions: review each one before running it.
Loading voting…