ansi_up cross-site scripting vulnerability
CVE-2021-3377GHSA-2v5f-23xc-v9qr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ansi_up 5.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ansi_up
- Affected
- < 5.0.0
- Fixed in
- 5.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2v5f-23xc-v9qr lists affected ranges: npm ansi_up >=0 <5.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2v5f-23xc-v9qr lists affected ranges: npm ansi_up >=0 <5.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-3377: 8.00% estimated exploitation activity in the next 30 days; percentile 94.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The npm package ansiup converts ANSI escape codes into HTML. In ansiup v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2v5f-23xc-v9qr
- Revision 1 · created ·
Published from osv record GHSA-2v5f-23xc-v9qr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-3377 Advisory: ansi_up cross-site scripting vulnerability IDs: CVE-2021-3377, GHSA-2v5f-23xc-v9qr Record: https://patchnext.com/advisories/cve-2021-3377 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ansi_up 5.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ansi_up: affected < 5.0.0; fixed in 5.0.0 ## Suggested inspection (read-only) - `npm ls ansi_up --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ansi_up. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2v5f-23xc-v9qr (OSV record GHSA-2v5f-23xc-v9qr lists affected ranges: npm ansi_up >=0 <5.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-2v5f-23xc-v9qr (GitHub-reviewed advisory GHSA-2v5f-23xc-v9qr lists affected ranges: npm ansi_up >=0 <5.0.0) Commands are suggestions: review each one before running it.
Loading voting…