Cross-site scripting in Products.CMFCore, Products.PluggableAuthService, Plone
CVE-2021-33507GHSA-35rg-466w-77h3
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI products-cmfcore
- Affected
- < 2.5.1
- Fixed in
- 2.5.1
PyPI products-pluggableauthservice
- Affected
- < 2.6.2
- Fixed in
- 2.6.2
PyPI plone
- Affected
- <= 5.2.4
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-35rg-466w-77h3 lists affected ranges: PyPI products-cmfcore >=0 =0 =0 <=5.2.4
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-35rg-466w-77h3 lists affected ranges: PyPI products-cmfcore >=0 =0 =0 <=5.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2021-33507: 0.75% estimated exploitation activity in the next 30 days; percentile 55.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Zope Products.CMFCore before 2.5.1 and Products.PluggableAuthService before 2.6.2, as used in Plone through 5.2.4 and other products, allow Reflected XSS.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-35rg-466w-77h3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-35rg-466w-77h3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-33507 Advisory: Cross-site scripting in Products.CMFCore, Products.PluggableAuthService, Plone IDs: CVE-2021-33507, GHSA-35rg-466w-77h3 Record: https://patchnext.com/advisories/cve-2021-33507 (revision 3, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: products-cmfcore 2.5.1; products-pluggableauthservice 2.6.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI products-cmfcore: affected < 2.5.1; fixed in 2.5.1 - PyPI products-pluggableauthservice: affected < 2.6.2; fixed in 2.6.2 - PyPI plone: affected <= 5.2.4 ## Suggested inspection (read-only) - `python -m pip show products-cmfcore`: prints the installed version. Run with the environment that serves production active. - `python -m pip show products-pluggableauthservice`: prints the installed version. Run with the environment that serves production active. - `python -m pip show plone`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on products-cmfcore, products-pluggableauthservice, plone. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-35rg-466w-77h3 (OSV record GHSA-35rg-466w-77h3 lists affected ranges: PyPI products-cmfcore >=0 =0 =0 <=5.2.4) - Verified: https://github.com/advisories/GHSA-35rg-466w-77h3 (GitHub-reviewed advisory GHSA-35rg-466w-77h3 lists affected ranges: PyPI products-cmfcore >=0 =0 =0 <=5.2.4) Commands are suggestions: review each one before running it.
Loading voting…