Plone XSS in User Fullname Property and File Upload
CVE-2021-3313GHSA-hprr-4vfq-fcxw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (plone 5.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI plone
- Affected
- < 5.2.4
- Fixed in
- 5.2.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hprr-4vfq-fcxw lists affected ranges: PyPI plone >=0 <5.2.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hprr-4vfq-fcxw lists affected ranges: PyPI plone >=0 <5.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-3313: 0.98% estimated exploitation activity in the next 30 days; percentile 62.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Plone CMS until version 5.2.4 has a stored Cross-Site Scripting (XSS) vulnerability in the user fullname property and the file upload functionality. The user's input data is not properly encoded when being echoed back to the user. This data can be interpreted as executable code by the browser and allows an attacker to execute JavaScript in the context of the victim's browser if the victim opens a vulnerable page containing an XSS payload.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hprr-4vfq-fcxw
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-hprr-4vfq-fcxw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-3313 Advisory: Plone XSS in User Fullname Property and File Upload IDs: CVE-2021-3313, GHSA-hprr-4vfq-fcxw Record: https://patchnext.com/advisories/cve-2021-3313 (revision 3, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: plone 5.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI plone: affected < 5.2.4; fixed in 5.2.4 ## Suggested inspection (read-only) - `python -m pip show plone`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on plone. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hprr-4vfq-fcxw (OSV record GHSA-hprr-4vfq-fcxw lists affected ranges: PyPI plone >=0 <5.2.4 (fixed)) - Verified: https://github.com/advisories/GHSA-hprr-4vfq-fcxw (GitHub-reviewed advisory GHSA-hprr-4vfq-fcxw lists affected ranges: PyPI plone >=0 <5.2.4) Commands are suggestions: review each one before running it.
Loading voting…