Invalid session token expiration
CVE-2021-32923GHSA-38j9-7pp9-2hjw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/vault 1.7.2, 1.6.5, 1.5.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.7.0, < 1.7.2>= 1.6.0, < 1.6.5>= 0.10.0, < 1.5.9
- Fixed in
- 1.7.2, 1.6.5, 1.5.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-38j9-7pp9-2hjw lists affected ranges: Go github.com/hashicorp/vault >=1.7.0 =1.6.0 =0.10.0 <1.5.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2021-32923: 1.38% estimated exploitation activity in the next 30 days; percentile 72.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
HashiCorp Vault and Vault Enterprise allowed the renewal of nearly-expired token leases and dynamic secret leases (specifically, those within 1 second of their maximum TTL), which caused them to be incorrectly treated as non-expiring during subsequent use. Fixed in 1.5.9, 1.6.5, and 1.7.2.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-38j9-7pp9-2hjw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32923 Advisory: Invalid session token expiration IDs: CVE-2021-32923, GHSA-38j9-7pp9-2hjw Record: https://patchnext.com/advisories/cve-2021-32923 (revision 1, source checked 26 Oct 2026, 14:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/vault 1.7.2, 1.6.5, 1.5.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hashicorp/vault: affected >= 1.7.0, < 1.7.2; >= 1.6.0, < 1.6.5; >= 0.10.0, < 1.5.9; fixed in 1.7.2, 1.6.5, 1.5.9 ## Suggested inspection (read-only) - Go github.com/hashicorp/vault: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hashicorp/vault. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-38j9-7pp9-2hjw (GitHub-reviewed advisory GHSA-38j9-7pp9-2hjw lists affected ranges: Go github.com/hashicorp/vault >=1.7.0 =1.6.0 =0.10.0 <1.5.9) Commands are suggestions: review each one before running it.
Loading voting…