Skip to content

← Actionable
Medium, CVSS 5.4

nbconvert vulnerable to cross-site scripting (XSS) via multiple exploit paths

CVE-2021-32862GHSA-9jmq-rx5f-8jwq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nbconvert 6.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2021-32862: 1.48% estimated exploitation activity in the next 30 days; percentile 73.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Most of the fixes will be in this repo, though, so having it here gives us the private fork to work on patches Below is currently a duplicate of the original report: ---- Received on security@ipython.org unedited, I'm not sure if we want to make it separate advisories. Pasted raw for now, feel free to edit or make separate advisories if you have the rights to. I think the most important is to switch back from nbviewer.jupyter.org -> nbviewer.org at the cloudflare level I guess ? There might be fastly involved as well. ---

Impact _What kind of vulnerability is it? Who is impacted?_

Patches _Has the problem been patched? What versions should users upgrade to?_

Workarounds _Is there a way for users to fix or remediate the vulnerability without upgrading?_

References _Are there any links users can visit to find out more?_

For more information If you have any questions or comments about this advisory: * Open an issue in example link to repo *…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record GHSA-9jmq-rx5f-8jwq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32862

Advisory: nbconvert vulnerable to cross-site scripting (XSS) via multiple exploit paths
IDs: CVE-2021-32862, GHSA-9jmq-rx5f-8jwq
Record: https://patchnext.com/advisories/cve-2021-32862 (revision 1, source checked 24 Oct 2026, 04:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nbconvert 6.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nbconvert: affected < 6.5.1; fixed in 6.5.1

## Suggested inspection (read-only)
- `python -m pip show nbconvert`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nbconvert.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9jmq-rx5f-8jwq (OSV record GHSA-9jmq-rx5f-8jwq lists affected ranges: PyPI nbconvert >=0 <6.5.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…