Skip to content

← Actionable
Medium, CVSS 6.1amended

iziModal Cross-site Scripting vulnerability

CVE-2021-32860GHSA-h685-83w4-3ph3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (izimodal 1.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm izimodal

    Affected
    < 1.6.1
    Fixed in
    1.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2021-32860: 0.58% estimated exploitation activity in the next 30 days; percentile 47.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

iziModal is a modal plugin with jQuery. Versions prior to 1.6.1 are vulnerable to cross-site scripting (XSS) when handling untrusted modal titles. An attacker who is able to influence the field title when creating a iziModal instance is able to supply arbitrary html or javascript code that will be rendered in the context of a user, potentially leading to XSS. Version 1.6.1 contains a patch for this issue

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h685-83w4-3ph3

  2. Revision 1 · created ·

    Published from osv record GHSA-h685-83w4-3ph3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32860

Advisory: iziModal Cross-site Scripting vulnerability
IDs: CVE-2021-32860, GHSA-h685-83w4-3ph3
Record: https://patchnext.com/advisories/cve-2021-32860 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: izimodal 1.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm izimodal: affected < 1.6.1; fixed in 1.6.1

## Suggested inspection (read-only)
- `npm ls izimodal --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on izimodal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h685-83w4-3ph3 (OSV record GHSA-h685-83w4-3ph3 lists affected ranges: npm izimodal >=0 <1.6.1 (fixed))
- Verified: https://github.com/advisories/GHSA-h685-83w4-3ph3 (GitHub-reviewed advisory GHSA-h685-83w4-3ph3 lists affected ranges: npm izimodal >=0 <1.6.1)

Commands are suggestions: review each one before running it.

Loading voting…