Skip to content

← Actionable
High, CVSS 8.7amended

StripComments filter contains a regular expression that is vulnerable to ReDOS (Regular Expression Denial of Service)

CVE-2021-32839GHSA-p5w8-wqhj-9hhf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sqlparse 0.4.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI sqlparse

    Affected
    >= 0.4.0, < 0.4.2
    Fixed in
    0.4.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-32839: 2.34% estimated exploitation activity in the next 30 days; percentile 83.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The formatter function that strips comments from a SQL contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service). The regular expression may cause exponential backtracking on strings containing many repetitions of '\r\n' in SQL comments. Patches The issues has been fixed in sqlparse 0.4.2. Workarounds Only the formatting feature that removes comments from SQL statements is affected by this regular expression. As a workaround don't use the sqlformat.format function with keyword stripcomments=True or the --strip-comments command line flag when using the sqlformat command line tool. References This issue was discovered by GitHub team members @erik-krogh and @yoff. It was found using a CodeQL query which identifies inefficient regular expressions. You can see the results of the query on python-sqlparse by following this link. For more information If you have any questions or comments about this advisory: Open an issue in sqlparse issue…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-p5w8-wqhj-9hhf

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-p5w8-wqhj-9hhf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32839

Advisory: StripComments filter contains a regular expression that is vulnerable to ReDOS (Regular Expression Denial of Service)
IDs: CVE-2021-32839, GHSA-p5w8-wqhj-9hhf
Record: https://patchnext.com/advisories/cve-2021-32839 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sqlparse 0.4.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI sqlparse: affected >= 0.4.0, < 0.4.2; fixed in 0.4.2

## Suggested inspection (read-only)
- `python -m pip show sqlparse`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sqlparse.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p5w8-wqhj-9hhf (OSV record GHSA-p5w8-wqhj-9hhf lists affected ranges: PyPI sqlparse >=0.4.0 <0.4.2 (fixed))
- Verified: https://github.com/advisories/GHSA-p5w8-wqhj-9hhf (GitHub-reviewed advisory GHSA-p5w8-wqhj-9hhf lists affected ranges: PyPI sqlparse >=0.4.0 <0.4.2)

Commands are suggestions: review each one before running it.

Loading voting…