Skip to content

← Actionable
High, CVSS 8.6amended

Insecure template handling in Express-handlebars

CVE-2021-32820GHSA-fr76-2wp8-fp92

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (express-handlebars 5.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2021-32820: 15.74% estimated exploitation activity in the next 30 days; percentile 96.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Express-handlebars is a Handlebars view engine for Express. Express-handlebars mixes pure template data with engine configuration options through the Express render API. More specifically, the layout parameter may trigger file disclosure vulnerabilities in downstream applications. This potential vulnerability is somewhat restricted in that only files with existing extentions (i.e. file.extension) can be included, files that lack an extension will have .handlebars appended to them. For complete details refer to the referenced GHSL-2021-018 report. Notes in documentation have been added to help users avoid this potential information exposure vulnerability. A fix is discussed in https://github.com/express-handlebars/express-handlebars/pull/163

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fr76-2wp8-fp92

  2. Revision 1 · created ·

    Published from osv record GHSA-fr76-2wp8-fp92

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32820

Advisory: Insecure template handling in Express-handlebars
IDs: CVE-2021-32820, GHSA-fr76-2wp8-fp92
Record: https://patchnext.com/advisories/cve-2021-32820 (revision 2, source checked 26 Oct 2026, 12:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: express-handlebars 5.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm express-handlebars: affected < 5.3.1; fixed in 5.3.1

## Suggested inspection (read-only)
- `npm ls express-handlebars --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on express-handlebars.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fr76-2wp8-fp92 (OSV record GHSA-fr76-2wp8-fp92 lists affected ranges: npm express-handlebars >=0 <5.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-fr76-2wp8-fp92 (GitHub-reviewed advisory GHSA-fr76-2wp8-fp92 lists affected ranges: npm express-handlebars >=0 <5.3.1)

Commands are suggestions: review each one before running it.

Loading voting…