Skip to content

← Actionable
High, CVSS 7.7amended

Remote Code Execution via Script (Python) objects under Python 3

CVE-2021-32811GHSA-g4gq-j4p2-j8fr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zope 5.3, 4.6.3; accesscontrol 5.2, 4.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI zope

    Affected
    >= 4.0, < 4.6.3>= 5.0, < 5.3
    Fixed in
    4.6.3, 5.3
  • PyPI accesscontrol

    Affected
    >= 4.0, < 4.3>= 5.0, < 5.2
    Fixed in
    4.3, 5.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-32811: 2.30% estimated exploitation activity in the next 30 days; percentile 83.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Background: The optional add-on package Products.PythonScripts adds Script (Python) to the list of content items a user can add to the Zope object database. Inside these scripts users can write Python code that is executed when rendered through the web. The code environment in these script objects is limited, it relies on the RestrictedPython package to provide a "safe" subset of Python instructions as well as the AccessControl package that defines security policies for execution in the context of a Zope application. Recently the AccessControl package was updated to fix a remote code execution security issue. A link to the security advisory is provided in the References section below. The bug tightens the AccessControl security policies for Zope by blocking access to unsafe classes inside the Python string module. You are only affected if the following are true: - You use Python 3 for your Zope deployment (Zope 4 on Python 2 is not affected) - You run Zope 4 below version…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-g4gq-j4p2-j8fr

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record PYSEC-2021-370

  4. Revision 1 · created ·

    Published from osv record GHSA-g4gq-j4p2-j8fr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32811

Advisory: Remote Code Execution via Script (Python) objects under Python 3
IDs: CVE-2021-32811, GHSA-g4gq-j4p2-j8fr
Record: https://patchnext.com/advisories/cve-2021-32811 (revision 4, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zope 5.3, 4.6.3; accesscontrol 5.2, 4.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI zope: affected >= 4.0, < 4.6.3; >= 5.0, < 5.3; fixed in 4.6.3, 5.3
- PyPI accesscontrol: affected >= 4.0, < 4.3; >= 5.0, < 5.2; fixed in 4.3, 5.2

## Suggested inspection (read-only)
- `python -m pip show zope`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show accesscontrol`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zope, accesscontrol.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g4gq-j4p2-j8fr (OSV record GHSA-g4gq-j4p2-j8fr lists affected ranges: PyPI zope >=4.0 =5.0 <5.3 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2021-370 (OSV record PYSEC-2021-370 lists affected ranges: PyPI accesscontrol >=4.0 =5.0 <5.2 (fixed))
- Verified: https://github.com/advisories/GHSA-g4gq-j4p2-j8fr (GitHub-reviewed advisory GHSA-g4gq-j4p2-j8fr lists affected ranges: PyPI zope >=4.0 =5.0 <5.3)

Commands are suggestions: review each one before running it.

Loading voting…