Clipboard feature vulnerability allowing to inject arbitrary HTML into the editor using paste functionality
CVE-2021-32809GHSA-7889-rm5j-hpgg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckeditor4 4.16.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ckeditor4
- Affected
- >= 4.5.2, < 4.16.2
- Fixed in
- 4.16.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7889-rm5j-hpgg lists affected ranges: npm ckeditor4 >=4.5.2 <4.16.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7889-rm5j-hpgg lists affected ranges: npm ckeditor4 >=4.5.2 <4.16.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2021-32809: 1.19% estimated exploitation activity in the next 30 days; percentile 67.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected packages The vulnerability has been discovered in clipboard plugin. All plugins with clipboard plugin dependency are affected: clipboard pastetext pastetools widget uploadwidget autolink tableselection Impact A potential vulnerability has been discovered in CKEditor 4 Clipboard package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version = 4.5.2. Patches The problem has been recognized and patched. The fix will be available in version 4.16.2. For more information Email us at security@cksource.com if you have any questions or comments about this advisory. Acknowledgements The CKEditor 4 team would like to thank Anton Subbotin (skavans) for recognizing and reporting this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7889-rm5j-hpgg
- Revision 1 · created ·
Published from osv record GHSA-7889-rm5j-hpgg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32809 Advisory: Clipboard feature vulnerability allowing to inject arbitrary HTML into the editor using paste functionality IDs: CVE-2021-32809, GHSA-7889-rm5j-hpgg Record: https://patchnext.com/advisories/cve-2021-32809 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ckeditor4 4.16.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ckeditor4: affected >= 4.5.2, < 4.16.2; fixed in 4.16.2 ## Suggested inspection (read-only) - `npm ls ckeditor4 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ckeditor4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7889-rm5j-hpgg (OSV record GHSA-7889-rm5j-hpgg lists affected ranges: npm ckeditor4 >=4.5.2 <4.16.2 (fixed)) - Verified: https://github.com/advisories/GHSA-7889-rm5j-hpgg (GitHub-reviewed advisory GHSA-7889-rm5j-hpgg lists affected ranges: npm ckeditor4 >=4.5.2 <4.16.2) Commands are suggestions: review each one before running it.
Loading voting…