Skip to content

← Actionable
Medium, CVSS 5.9amended

Remote Code Execution via unsafe classes in otherwise permitted modules

CVE-2021-32807GHSA-qcx9-j53g-ccgf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zope 5.2, 4.3; accesscontrol 5.2, 4.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI zope

    Affected
    >= 4.0, < 4.3>= 5.0, < 5.2
    Fixed in
    5.2, 4.3
  • PyPI accesscontrol

    Affected
    >= 4.0, < 4.3>= 5.0, < 5.2
    Fixed in
    5.2, 4.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-32807: 2.05% estimated exploitation activity in the next 30 days; percentile 81.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The module AccessControl defines security policies for Python code used in restricted code within Zope applications. Restricted code is any code that resides in Zope's object database, such as the contents of Script (Python) objects. The policies defined in AccessControl severely restrict access to Python modules and only exempt a few that are deemed safe, such as Python's string module. However, full access to the string module also allows access to the class Formatter, which can be overridden and extended within Script (Python) in a way that provides access to other unsafe Python libraries. Those unsafe Python libraries can be used for remote code execution. By default, you need to have the admin-level Zope "Manager" role to add or edit Script (Python) objects through the web. Only sites that allow untrusted users to add/edit these scripts through the web - which would be a very unusual configuration to begin with - are at risk. Patches The problem has been fixed in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qcx9-j53g-ccgf

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-qcx9-j53g-ccgf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32807

Advisory: Remote Code Execution via unsafe classes in otherwise permitted modules
IDs: CVE-2021-32807, GHSA-qcx9-j53g-ccgf
Record: https://patchnext.com/advisories/cve-2021-32807 (revision 3, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zope 5.2, 4.3; accesscontrol 5.2, 4.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI zope: affected >= 4.0, < 4.3; >= 5.0, < 5.2; fixed in 5.2, 4.3
- PyPI accesscontrol: affected >= 4.0, < 4.3; >= 5.0, < 5.2; fixed in 5.2, 4.3

## Suggested inspection (read-only)
- `python -m pip show zope`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show accesscontrol`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zope, accesscontrol.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qcx9-j53g-ccgf (OSV record GHSA-qcx9-j53g-ccgf lists affected ranges: PyPI accesscontrol >=4.0 =5.0 =4.0 =5.0 <5.2 (fixed))
- Verified: https://github.com/advisories/GHSA-qcx9-j53g-ccgf (GitHub-reviewed advisory GHSA-qcx9-j53g-ccgf lists affected ranges: PyPI accesscontrol >=4.0 =5.0 =4.0 =5.0 <5.2)

Commands are suggestions: review each one before running it.

Loading voting…