Skip to content

← Actionable
High, CVSS 8.2amended

Arbitrary File Creation/Overwrite due to insufficient absolute path sanitization

CVE-2021-32804GHSA-3jfq-g458-7qm9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tar 6.1.1, 5.0.6, 4.4.14, 3.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm tar

    Affected
    < 3.2.2>= 4.0.0, < 4.4.14>= 5.0.0, < 5.0.6>= 6.0.0, < 6.1.1
    Fixed in
    3.2.2, 4.4.14, 6.1.1, 5.0.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2021-32804: 15.07% estimated exploitation activity in the next 30 days; percentile 96.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Arbitrary File Creation, Arbitrary File Overwrite, Arbitrary Code Execution node-tar aims to prevent extraction of absolute file paths by turning absolute paths into relative paths when the preservePaths flag is not set to true. This is achieved by stripping the absolute path root from any absolute file paths contained in a tar file. For example /home/user/.bashrc would turn into home/user/.bashrc. This logic was insufficient when file paths contained repeated path roots such as ////home/user/.bashrc. node-tar would only strip a single path root from such paths. When given an absolute file path with repeating path roots, the resulting path (e.g. ///home/user/.bashrc) would still resolve to an absolute path, thus allowing arbitrary file creation and overwrite. Patches 3.2.2 || 4.4.14 || 5.0.6 || 6.1.1 NOTE: an adjacent issue CVE-2021-32803 affects this release level. Please ensure you update to the latest patch levels that address CVE-2021-32803 as well if this adjacent issue…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3jfq-g458-7qm9

  2. Revision 1 · created ·

    Published from osv record GHSA-3jfq-g458-7qm9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32804

Advisory: Arbitrary File Creation/Overwrite due to insufficient absolute path sanitization
IDs: CVE-2021-32804, GHSA-3jfq-g458-7qm9
Record: https://patchnext.com/advisories/cve-2021-32804 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tar 6.1.1, 5.0.6, 4.4.14, 3.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm tar: affected < 3.2.2; >= 4.0.0, < 4.4.14; >= 5.0.0, < 5.0.6; >= 6.0.0, < 6.1.1; fixed in 3.2.2, 4.4.14, 6.1.1, 5.0.6

## Suggested inspection (read-only)
- `npm ls tar --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tar.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3jfq-g458-7qm9 (OSV record GHSA-3jfq-g458-7qm9 lists affected ranges: npm tar >=0 =4.0.0 =5.0.0 =6.0.0 <6.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-3jfq-g458-7qm9 (GitHub-reviewed advisory GHSA-3jfq-g458-7qm9 lists affected ranges: npm tar >=0 =4.0.0 =5.0.0 =6.0.0 <6.1.1)

Commands are suggestions: review each one before running it.

Loading voting…