JupyterLab: XSS due to lack of sanitization of the action attribute of an html
CVE-2021-32797GHSA-4952-p58q-6crx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterlab 3.1.4, 3.0.17, 2.3.2, 2.2.10, 1.2.21; notebook 6.4.1, 5.7.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyterlab
- Affected
- < 1.2.21>= 2.0.0a0, < 2.2.10>= 2.3.0a0, < 2.3.2>= 3.0.0a0, < 3.0.17>= 3.1.0a0, < 3.1.4
- Fixed in
- 3.0.17, 2.2.10, 1.2.21, 3.1.4, 2.3.2
PyPI notebook
- Affected
- < 5.7.11>= 6.0.0, < 6.4.1
- Fixed in
- 6.4.1, 5.7.11
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4952-p58q-6crx lists affected ranges: PyPI jupyterlab >=0 =2.0.0a0 =2.3.0a0 =3.0.0a0 =3.1.0a0 =0 =6.0.0 <6.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4952-p58q-6crx lists affected ranges: PyPI jupyterlab >=0 =2.0.0a0 =2.3.0a0 =3.0.0a0 =3.1.0a0 =0 =6.0.0 <6.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N · score source
- EPSS
- CVE-2021-32797: 2.66% estimated exploitation activity in the next 30 days; percentile 85.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Untrusted notebook can execute code on load. This is a remote code execution, but requires user action to open a notebook. Patches Patched in the following versions: 3.1.4, 3.0.17, 2.3.2, 2.2.10, 1.2.21. References OWASP Page on Restricting Form Submissions For more information If you have any questions or comments about this advisory, or vulnerabilities to report, please email our security list security@ipython.org. Credit: Guillaume Jeanne from Google
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4952-p58q-6crx
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4952-p58q-6crx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32797 Advisory: JupyterLab: XSS due to lack of sanitization of the action attribute of an html IDs: CVE-2021-32797, GHSA-4952-p58q-6crx Record: https://patchnext.com/advisories/cve-2021-32797 (revision 3, source checked 26 Oct 2026, 13:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyterlab 3.1.4, 3.0.17, 2.3.2, 2.2.10, 1.2.21; notebook 6.4.1, 5.7.11. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyterlab: affected < 1.2.21; >= 2.0.0a0, < 2.2.10; >= 2.3.0a0, < 2.3.2; >= 3.0.0a0, < 3.0.17; >= 3.1.0a0, < 3.1.4; fixed in 3.0.17, 2.2.10, 1.2.21, 3.1.4, 2.3.2 - PyPI notebook: affected < 5.7.11; >= 6.0.0, < 6.4.1; fixed in 6.4.1, 5.7.11 ## Suggested inspection (read-only) - `python -m pip show jupyterlab`: prints the installed version. Run with the environment that serves production active. - `python -m pip show notebook`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyterlab, notebook. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4952-p58q-6crx (OSV record GHSA-4952-p58q-6crx lists affected ranges: PyPI jupyterlab >=0 =2.0.0a0 =2.3.0a0 =3.0.0a0 =3.1.0a0 =0 =6.0.0 <6.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-4952-p58q-6crx (GitHub-reviewed advisory GHSA-4952-p58q-6crx lists affected ranges: PyPI jupyterlab >=0 =2.0.0a0 =2.3.0a0 =3.0.0a0 =3.1.0a0 =0 =6.0.0 <6.4.1) Commands are suggestions: review each one before running it.
Loading voting…