Cross-Site Scripting via Rich-Text Content
CVE-2021-32768GHSA-c5c9-8c6m-727v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-core 11.3.2, 10.4.19, 9.5.29, 8.7.42, 7.6.53; typo3/cms 11.3.2, 10.4.19, 9.5.29, 8.7.42, 7.6.53), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist typo3/cms-core
- Affected
- >= 7.0.0, < 7.6.53>= 8.0.0, < 8.7.42>= 10.0.0, < 10.4.19>= 11.0.0, < 11.3.2>= 9.0.0, < 9.5.29
- Fixed in
- 10.4.19, 11.3.2, 8.7.42, 7.6.53, 9.5.29
Packagist typo3/cms
- Affected
- >= 10.0.0, < 10.4.19>= 11.0.0, < 11.3.2>= 9.0.0, < 9.5.29>= 8.0.0, < 8.7.42>= 7.0.0, < 7.6.53
- Fixed in
- 10.4.19, 11.3.2, 8.7.42, 7.6.53, 9.5.29
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c5c9-8c6m-727v lists affected ranges: Packagist typo3/cms-core >=7.0.0 =8.0.0 =10.0.0 =11.0.0 =9.0.0 =10.0.0 =11.0.0 =9.0.0 =8.0.0 =7.0.0 <7.6.53
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-32768: 0.73% estimated exploitation activity in the next 30 days; percentile 54.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Meta CVSS: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC (5.7) Problem Failing to properly parse, sanitize and encode malicious rich-text content, the content rendering process in the website frontend is vulnerable to cross-site scripting. Corresponding rendering instructions via TypoScript functionality HTMLparser do not consider all potentially malicious HTML tag & attribute combinations per default. In addition, the lack of comprehensive default node configuration for rich-text fields in the backend user interface fosters this malfunction. In default scenarios, a valid backend user account is needed to exploit this vulnerability. In case custom plugins used in the website frontend accept and reflect rich-text content submitted by users, no authentication is required. Solution Update to TYPO3 versions 7.6.53 ELTS, 8.7.42 ELTS, 9.5.29, 10.4.19, 11.3.2 that fix the problem described above. Custom package typo3/html-sanitizer - based on allow-lists only - takes care of…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c5c9-8c6m-727v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32768 Advisory: Cross-Site Scripting via Rich-Text Content IDs: CVE-2021-32768, GHSA-c5c9-8c6m-727v Record: https://patchnext.com/advisories/cve-2021-32768 (revision 1, source checked 26 Oct 2026, 14:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: typo3/cms-core 11.3.2, 10.4.19, 9.5.29, 8.7.42, 7.6.53; typo3/cms 11.3.2, 10.4.19, 9.5.29, 8.7.42, 7.6.53. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist typo3/cms-core: affected >= 7.0.0, < 7.6.53; >= 8.0.0, < 8.7.42; >= 10.0.0, < 10.4.19; >= 11.0.0, < 11.3.2; >= 9.0.0, < 9.5.29; fixed in 10.4.19, 11.3.2, 8.7.42, 7.6.53, 9.5.29 - Packagist typo3/cms: affected >= 10.0.0, < 10.4.19; >= 11.0.0, < 11.3.2; >= 9.0.0, < 9.5.29; >= 8.0.0, < 8.7.42; >= 7.0.0, < 7.6.53; fixed in 10.4.19, 11.3.2, 8.7.42, 7.6.53, 9.5.29 ## Suggested inspection (read-only) - Packagist typo3/cms-core: check the installed version with your package manager. - Packagist typo3/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on typo3/cms-core, typo3/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c5c9-8c6m-727v (GitHub-reviewed advisory GHSA-c5c9-8c6m-727v lists affected ranges: Packagist typo3/cms-core >=7.0.0 =8.0.0 =10.0.0 =11.0.0 =9.0.0 =10.0.0 =11.0.0 =9.0.0 =8.0.0 =7.0.0 <7.6.53) Commands are suggestions: review each one before running it.
Loading voting…