Archive package allows chmod of file outside of unpack target directory
CVE-2021-32760GHSA-c72p-9xmj-rx3w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/containerd/containerd 1.5.4, 1.4.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/containerd/containerd
- Affected
- < 1.4.8>= 1.5.0, < 1.5.4
- Fixed in
- 1.4.8, 1.5.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c72p-9xmj-rx3w lists affected ranges: Go github.com/containerd/containerd >=0 =1.5.0 <1.5.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
- EPSS
- CVE-2021-32760: 1.59% estimated exploitation activity in the next 30 days; percentile 75.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A bug was found in containerd where pulling and extracting a specially-crafted container image can result in Unix file permission changes for existing files in the host’s filesystem. Changes to file permissions can deny access to the expected owner of the file, widen access to others, or set extended bits like setuid, setgid, and sticky. This bug does not directly allow files to be read, modified, or executed without an additional cooperating process. Patches This bug has been fixed in containerd 1.5.4 and 1.4.8. Users should update to these versions as soon as they are released. Running containers do not need to be restarted. Workarounds Ensure you only pull images from trusted sources. Linux security modules (LSMs) like SELinux and AppArmor can limit the files potentially affected by this bug through policies and profiles that prevent containerd from interacting with unexpected files. For more information If you have any questions or comments about this advisory: Open an…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c72p-9xmj-rx3w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32760 Advisory: Archive package allows chmod of file outside of unpack target directory IDs: CVE-2021-32760, GHSA-c72p-9xmj-rx3w Record: https://patchnext.com/advisories/cve-2021-32760 (revision 1, source checked 26 Oct 2026, 15:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/containerd/containerd 1.5.4, 1.4.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/containerd/containerd: affected < 1.4.8; >= 1.5.0, < 1.5.4; fixed in 1.4.8, 1.5.4 ## Suggested inspection (read-only) - Go github.com/containerd/containerd: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/containerd/containerd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c72p-9xmj-rx3w (GitHub-reviewed advisory GHSA-c72p-9xmj-rx3w lists affected ranges: Go github.com/containerd/containerd >=0 =1.5.0 <1.5.4) Commands are suggestions: review each one before running it.
Loading voting…