Skip to content

← Actionable
High, CVSS 7.5

Regular Expression Denial of Service in Addressable templates

CVE-2021-32740GHSA-jxhc-q857-3j6g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (addressable 2.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems addressable

    Affected
    >= 2.3.0, <= 2.7.0
    Fixed in
    2.8.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2021-32740: 2.14% estimated exploitation activity in the next 30 days; percentile 82.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Within the URI template implementation in Addressable, a maliciously crafted template may result in uncontrolled resource consumption, leading to denial of service when matched against a URI. In typical usage, templates would not normally be read from untrusted user input, but nonetheless, no previous security advisory for Addressable has cautioned against doing this. Users of the parsing capabilities in Addressable but not the URI template capabilities are unaffected. Patches The vulnerability was introduced in version 2.3.0 (previously yanked) and has been present in all subsequent versions up to, and including, 2.7.0. It is fixed in version 2.8.0. Workarounds The vulnerability can be avoided by only creating Template objects from trusted sources that have been validated not to produce catastrophic backtracking. References - https://owasp.org/www-community/attacks/RegularexpressionDenialofService-ReDoS - https://cwe.mitre.org/data/definitions/1333.html -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jxhc-q857-3j6g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32740

Advisory: Regular Expression Denial of Service in Addressable templates
IDs: CVE-2021-32740, GHSA-jxhc-q857-3j6g
Record: https://patchnext.com/advisories/cve-2021-32740 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: addressable 2.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems addressable: affected >= 2.3.0, <= 2.7.0; fixed in 2.8.0

## Suggested inspection (read-only)
- RubyGems addressable: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on addressable.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jxhc-q857-3j6g (GitHub-reviewed advisory GHSA-jxhc-q857-3j6g lists affected ranges: RubyGems addressable >=2.3.0 <=2.7.0)

Commands are suggestions: review each one before running it.

Loading voting…