Skip to content

← Actionable
High, CVSS 7.5amended

Prototype Pollution in think-helper

CVE-2021-32736GHSA-vr5m-3h59-7jcp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (think-helper 1.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2021-32736: 1.01% estimated exploitation activity in the next 30 days; percentile 63.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The software receives input from an upstream component that specifies attributes that are to be initialized or updated in an object, but it does not properly control modifications of attributes of the object prototype. Patches think-helper@1.1.3 patched it, anyone used think-helper should upgrade to =1.1.3 version. References https://cwe.mitre.org/data/definitions/1321.html For more information If you have any questions or comments about this advisory: Open an issue in thinkjs/thinkjs Email us at i@imnerd.org

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vr5m-3h59-7jcp

  2. Revision 1 · created ·

    Published from osv record GHSA-vr5m-3h59-7jcp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32736

Advisory: Prototype Pollution in think-helper
IDs: CVE-2021-32736, GHSA-vr5m-3h59-7jcp
Record: https://patchnext.com/advisories/cve-2021-32736 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: think-helper 1.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm think-helper: affected < 1.1.3; fixed in 1.1.3

## Suggested inspection (read-only)
- `npm ls think-helper --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on think-helper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vr5m-3h59-7jcp (OSV record GHSA-vr5m-3h59-7jcp lists affected ranges: npm think-helper >=0 <1.1.3 (fixed))
- Verified: https://github.com/advisories/GHSA-vr5m-3h59-7jcp (GitHub-reviewed advisory GHSA-vr5m-3h59-7jcp lists affected ranges: npm think-helper >=0 <1.1.3)

Commands are suggestions: review each one before running it.

Loading voting…