A user without PR can reset user authentication failures information
CVE-2021-32729GHSA-m738-3rc4-5xv3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-security-authentication-script 12.10.4, 12.6.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-security-authentication-script
- Affected
- >= 11.6, < 12.6.8>= 12.7, < 12.10.4
- Fixed in
- 12.6.8, 12.10.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m738-3rc4-5xv3 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-security-authentication-script >=11.6 =12.7 <12.10.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.0 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N
- EPSS
- CVE-2021-32729: 0.50% estimated exploitation activity in the next 30 days; percentile 42.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The script service method used to reset the authentication failures record can be executed by any user with Script rights and does not require Programming rights as it should have. Note that being able to reset the authentication failure record mean that an attacker with script right might use it to try performing a bruteforce attack since she'd been able to virtually deactivate the mechanism introduced to mitigate those attacks. Patches The problem has been patched in version 12.6.8, 12.10.4 and 13.0. Workarounds There's no workaround besides upgrading and being careful on which user should have Script right access. Note that any bruteforce attack on the authentication should be visible in the logs since the authentication failures are logged. References https://jira.xwiki.org/browse/XWIKI-18276 For more information If you have any questions or comments about this advisory: Open an issue in Jira Email us at the security mailing-list
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m738-3rc4-5xv3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32729 Advisory: A user without PR can reset user authentication failures information IDs: CVE-2021-32729, GHSA-m738-3rc4-5xv3 Record: https://patchnext.com/advisories/cve-2021-32729 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-security-authentication-script 12.10.4, 12.6.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-security-authentication-script: affected >= 11.6, < 12.6.8; >= 12.7, < 12.10.4; fixed in 12.6.8, 12.10.4 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-security-authentication-script: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-security-authentication-script. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m738-3rc4-5xv3 (GitHub-reviewed advisory GHSA-m738-3rc4-5xv3 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-security-authentication-script >=11.6 =12.7 <12.10.4) Commands are suggestions: review each one before running it.
Loading voting…