Regular Expression Denial of Service (ReDoS) in Prism
CVE-2021-32723GHSA-gj77-59wh-66hg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (prismjs 1.24.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm prismjs
- Affected
- < 1.24.0
- Fixed in
- 1.24.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gj77-59wh-66hg lists affected ranges: npm prismjs >=0 <1.24.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gj77-59wh-66hg lists affected ranges: npm prismjs >=0 <1.24.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:H
- EPSS
- CVE-2021-32723: 1.42% estimated exploitation activity in the next 30 days; percentile 72.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Some languages before 1.24.0 are vulnerable to Regular Expression Denial of Service (ReDoS). Impact When Prism is used to highlight untrusted (user-given) text, an attacker can craft a string that will take a very very long time to highlight. Do not use the following languages to highlight untrusted text. - ASCIIDoc - ERB Other languages are not affected and can be used to highlight untrusted text. Patches This problem has been fixed in Prism v1.24. References - PrismJS/prism#2774 - PrismJS/prism#2688
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gj77-59wh-66hg
- Revision 1 · created ·
Published from osv record GHSA-gj77-59wh-66hg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32723 Advisory: Regular Expression Denial of Service (ReDoS) in Prism IDs: CVE-2021-32723, GHSA-gj77-59wh-66hg Record: https://patchnext.com/advisories/cve-2021-32723 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: prismjs 1.24.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm prismjs: affected < 1.24.0; fixed in 1.24.0 ## Suggested inspection (read-only) - `npm ls prismjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on prismjs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gj77-59wh-66hg (OSV record GHSA-gj77-59wh-66hg lists affected ranges: npm prismjs >=0 <1.24.0 (fixed)) - Verified: https://github.com/advisories/GHSA-gj77-59wh-66hg (GitHub-reviewed advisory GHSA-gj77-59wh-66hg lists affected ranges: npm prismjs >=0 <1.24.0) Commands are suggestions: review each one before running it.
Loading voting…