Lenient Parsing of Content-Length Header When Prefixed with Plus Sign
CVE-2021-32715GHSA-f3pg-qwvg-p99c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (hyper 0.14.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io hyper
- Affected
- < 0.14.10
- Fixed in
- 0.14.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f3pg-qwvg-p99c lists affected ranges: crates.io hyper >=0 <0.14.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
- EPSS
- CVE-2021-32715: 1.13% estimated exploitation activity in the next 30 days; percentile 66.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary hyper's HTTP/1 server code had a flaw that incorrectly parses and accepts requests with a Content-Length header with a prefixed plus sign, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that doesn't parse such Content-Length headers, but forwards them, can result in "request smuggling" or "desync attacks". Vulnerability The flaw exists in all prior versions of hyper, if built with rustc v1.5.0 or newer. Example: This request gets accepted and hyper reads the body as abc. The request should be rejected, according to RFC 7230, since the ABNF for Content-Length only allows for DIGITs. This is due to using the FromStr implementation for u64 in the standard library. By differing from the spec, it is possible to send requests like these to endpoints that have different HTTP implementations, with different interpretations of the payload semantics, and cause "desync attacks". In this particular case, an upstream proxy would need to error when…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f3pg-qwvg-p99c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32715 Advisory: Lenient Parsing of Content-Length Header When Prefixed with Plus Sign IDs: CVE-2021-32715, GHSA-f3pg-qwvg-p99c Record: https://patchnext.com/advisories/cve-2021-32715 (revision 1, source checked 26 Oct 2026, 15:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: hyper 0.14.10. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io hyper: affected < 0.14.10; fixed in 0.14.10 ## Suggested inspection (read-only) - crates.io hyper: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on hyper. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f3pg-qwvg-p99c (GitHub-reviewed advisory GHSA-f3pg-qwvg-p99c lists affected ranges: crates.io hyper >=0 <0.14.10) Commands are suggestions: review each one before running it.
Loading voting…