Integer Overflow in Chunked Transfer-Encoding
CVE-2021-32714GHSA-5h46-h7hh-c6x9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (hyper 0.14.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io hyper
- Affected
- < 0.14.10
- Fixed in
- 0.14.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5h46-h7hh-c6x9 lists affected ranges: crates.io hyper >=0 <0.14.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-32714: 1.16% estimated exploitation activity in the next 30 days; percentile 67.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary hyper's HTTP server and client code had a flaw that could trigger an integer overflow when decoding chunk sizes that are too big. This allows possible data loss, or if combined with an upstream HTTP proxy that allows chunk sizes larger than hyper does, can result in "request smuggling" or "desync attacks". Vulnerability Example: hyper only reads the rightmost 64-bit integer as the chunk size. So it reads f0000000000000003 as 3. A loss of data can occur since hyper would then read only 3 bytes of the body. Additionally, an HTTP request smuggling vulnerability would occur if using a proxy which instead has prefix truncation in the chunk size, or that understands larger than 64-bit chunk sizes. Read more about desync attacks: https://portswigger.net/research/http-desync-attacks-request-smuggling-reborn Impact To determine if vulnerable to data loss, these things must be true: - Using HTTP/1.1. Since HTTP/2 does not use chunked encoding, it is not vulnerable. - Using hyper as a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5h46-h7hh-c6x9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32714 Advisory: Integer Overflow in Chunked Transfer-Encoding IDs: CVE-2021-32714, GHSA-5h46-h7hh-c6x9 Record: https://patchnext.com/advisories/cve-2021-32714 (revision 1, source checked 26 Oct 2026, 15:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: hyper 0.14.10. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io hyper: affected < 0.14.10; fixed in 0.14.10 ## Suggested inspection (read-only) - crates.io hyper: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on hyper. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5h46-h7hh-c6x9 (GitHub-reviewed advisory GHSA-5h46-h7hh-c6x9 lists affected ranges: crates.io hyper >=0 <0.14.10) Commands are suggestions: review each one before running it.
Loading voting…