Time-of-check Time-of-use (TOCTOU) Race Condition in league/flysystem
CVE-2021-32708GHSA-9f46-5r25-5wfm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (league/flysystem 2.1.1, 1.1.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist league/flysystem
- Affected
- < 1.1.4>= 2.0.0, < 2.1.1
- Fixed in
- 1.1.4, 2.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9f46-5r25-5wfm lists affected ranges: Packagist league/flysystem >=0 =2.0.0 <2.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-32708: 3.49% estimated exploitation activity in the next 30 days; percentile 89.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The whitespace normalisation using in 1.x and 2.x removes any unicode whitespace. Under certain specific conditions this could potentially allow a malicious user to execute code remotely. The conditions: - A user is allowed to supply the path or filename of an uploaded file. - The supplied path or filename is not checked against unicode chars. - The supplied pathname checked against an extension deny-list, not an allow-list. - The supplied path or filename contains a unicode whitespace char in the extension. - The uploaded file is stored in a directory that allows PHP code to be executed. Given these conditions are met a user can upload and execute arbitrary code on the system under attack. Patches The unicode whitespace removal has been replaced with a rejection (exception). The library has been patched in: - 1.x: https://github.com/thephpleague/flysystem/commit/f3ad69181b8afed2c9edf7be5a2918144ff4ea32 - 2.x:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9f46-5r25-5wfm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32708 Advisory: Time-of-check Time-of-use (TOCTOU) Race Condition in league/flysystem IDs: CVE-2021-32708, GHSA-9f46-5r25-5wfm Record: https://patchnext.com/advisories/cve-2021-32708 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: league/flysystem 2.1.1, 1.1.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist league/flysystem: affected < 1.1.4; >= 2.0.0, < 2.1.1; fixed in 1.1.4, 2.1.1 ## Suggested inspection (read-only) - Packagist league/flysystem: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on league/flysystem. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9f46-5r25-5wfm (GitHub-reviewed advisory GHSA-9f46-5r25-5wfm lists affected ranges: Packagist league/flysystem >=0 =2.0.0 <2.1.1) Commands are suggestions: review each one before running it.
Loading voting…