Skip to content

← Actionable
Medium, CVSS 6.5

Form validation can be skipped

CVE-2021-32697GHSA-m5vx-8chx-qvmm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (neos/form 5.1.3, 5.0.9, 4.3.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist neos/form

    Affected
    >= 1.2.0, < 4.3.3>= 5.0.0, < 5.0.9>= 5.1.0, < 5.1.3
    Fixed in
    5.1.3, 5.0.9, 4.3.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2021-32697: 1.12% estimated exploitation activity in the next 30 days; percentile 66.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact By crafting a special GET request containing a valid form state, a form can be submitted without invoking any validators. We consider the severity low because it is not possible to change any form values since the form state is secured with an HMAC that is still verified. That means that this issue can only be exploited if Form Finishers cause side effects even if no form values have been sent. Patches https://github.com/neos/form/commit/69de4219b1f58157e2be6b05811463875d75c246 Workarounds Form Finishers can be adjusted in a way that they only execute an action if the submitted form contains some expected data. Alternatively a custom Finisher can be added as first finisher. References This regression was introduced with https://github.com/neos/form/commit/049d415295be8d4a0478ccba97dba1bb81649567 Original report: https://tickets.neos.io/#ticket/zoom/411 (internal)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m5vx-8chx-qvmm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32697

Advisory: Form validation can be skipped
IDs: CVE-2021-32697, GHSA-m5vx-8chx-qvmm
Record: https://patchnext.com/advisories/cve-2021-32697 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: neos/form 5.1.3, 5.0.9, 4.3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist neos/form: affected >= 1.2.0, < 4.3.3; >= 5.0.0, < 5.0.9; >= 5.1.0, < 5.1.3; fixed in 5.1.3, 5.0.9, 4.3.3

## Suggested inspection (read-only)
- Packagist neos/form: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on neos/form.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m5vx-8chx-qvmm (GitHub-reviewed advisory GHSA-m5vx-8chx-qvmm lists affected ranges: Packagist neos/form >=1.2.0 =5.0.0 =5.1.0 <5.1.3)

Commands are suggestions: review each one before running it.

Loading voting…