Auto-merging Person Records Compromised
CVE-2021-32691GHSA-r578-pj6f-r4ff
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@apollosproject/data-connector-rock 2.20.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @apollosproject/data-connector-rock
- Affected
- < 2.20.0
- Fixed in
- 2.20.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r578-pj6f-r4ff lists affected ranges: npm @apollosproject/data-connector-rock >=0 <2.20.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r578-pj6f-r4ff lists affected ranges: npm @apollosproject/data-connector-rock >=0 <2.20.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-32691: 1.46% estimated exploitation activity in the next 30 days; percentile 73.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact New user registrations are able to access anyone's account by only knowing their basic profile information (name, birthday, gender, etc). This includes all app functionality within the app, as well as any authenticated links to Rock-based webpages (such as giving and events). Patches We have released a security patch on v2.20.0. The solution was to create a duplicate person and then patch the new person with their profile details. Workarounds If you do not wish to upgrade your app to the new version, you can patch your server by overriding the create data source method on the People class. For more information If you have any questions or comments about this advisory: Email us at support@apollos.app
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r578-pj6f-r4ff
- Revision 1 · created ·
Published from osv record GHSA-r578-pj6f-r4ff
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32691 Advisory: Auto-merging Person Records Compromised IDs: CVE-2021-32691, GHSA-r578-pj6f-r4ff Record: https://patchnext.com/advisories/cve-2021-32691 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @apollosproject/data-connector-rock 2.20.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @apollosproject/data-connector-rock: affected < 2.20.0; fixed in 2.20.0 ## Suggested inspection (read-only) - `npm ls @apollosproject/data-connector-rock --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @apollosproject/data-connector-rock. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r578-pj6f-r4ff (OSV record GHSA-r578-pj6f-r4ff lists affected ranges: npm @apollosproject/data-connector-rock >=0 <2.20.0 (fixed)) - Verified: https://github.com/advisories/GHSA-r578-pj6f-r4ff (GitHub-reviewed advisory GHSA-r578-pj6f-r4ff lists affected ranges: npm @apollosproject/data-connector-rock >=0 <2.20.0) Commands are suggestions: review each one before running it.
Loading voting…