Skip to content

← Actionable
Critical, CVSS 9.8amended

Improper Verification of Cryptographic Signature

CVE-2021-32685GHSA-7r96-8g3x-g36m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tenvoy 7.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm tenvoy

    Affected
    < 7.0.3
    Fixed in
    7.0.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-32685: 0.66% estimated exploitation activity in the next 30 days; percentile 51.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The verifyWithMessage method of tEnvoyNaClSigningKey always returns true for any signature of a SHA-512 hash matching the SHA-512 hash of the message even if the signature is invalid. Patches Upgrade to v7.0.3 immediately to resolve this issue. Since the vulnerability lies within the verification method, the previous signatures are still valid. We highly recommend reverifying any signatures that were previously verified with the vulnerable verifyWithMessage method. Workarounds In tenvoy.js under the verifyWithMessage method definition within the tEnvoyNaClSigningKey class, ensure that the return statement call to this.verify ends in .verified. For example, the return statement should start with return this.verify(signed, password).verified && instead of return this.verify(signed, password) && . For more information If you have any questions or comments about this advisory: Open an issue in github.com/TogaTech/tEnvoy

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7r96-8g3x-g36m

  2. Revision 1 · created ·

    Published from osv record GHSA-7r96-8g3x-g36m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32685

Advisory: Improper Verification of Cryptographic Signature
IDs: CVE-2021-32685, GHSA-7r96-8g3x-g36m
Record: https://patchnext.com/advisories/cve-2021-32685 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tenvoy 7.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm tenvoy: affected < 7.0.3; fixed in 7.0.3

## Suggested inspection (read-only)
- `npm ls tenvoy --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tenvoy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7r96-8g3x-g36m (OSV record GHSA-7r96-8g3x-g36m lists affected ranges: npm tenvoy >=0 <7.0.3 (fixed))
- Verified: https://github.com/advisories/GHSA-7r96-8g3x-g36m (GitHub-reviewed advisory GHSA-7r96-8g3x-g36m lists affected ranges: npm tenvoy >=0 <7.0.3)

Commands are suggestions: review each one before running it.

Loading voting…