Skip to content

← Actionable
Medium, CVSS 5.1amended

Cross-site Scripting in wagtail

CVE-2021-32681GHSA-xfrw-hxr5-ghqf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 2.13.2, 2.12.5, 2.11.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI wagtail

    Affected
    < 2.11.8>= 2.12, < 2.12.5>= 2.13, < 2.13.2
    Fixed in
    2.12.5, 2.11.8, 2.13.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2021-32681: 1.11% estimated exploitation activity in the next 30 days; percentile 65.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When the {% includeblock %} template tag is used to output the value of a plain-text StreamField block (CharBlock, TextBlock or a similar user-defined block derived from FieldBlock), and that block does not specify a template for rendering, the tag output is not properly escaped as HTML. This could allow users to insert arbitrary HTML or scripting. This vulnerability is only exploitable by users with the ability to author StreamField content (i.e. users with 'editor' access to the Wagtail admin). Patches Patched versions have been released as Wagtail 2.11.8 (for the LTS 2.11 branch), Wagtail 2.12.5, and Wagtail 2.13.2 (for the current 2.13 branch). Site implementors who wish to retain the existing behaviour of allowing editors to insert HTML content in these blocks (and are willing to accept the risk of untrusted editors inserting arbitrary code) may disable the escaping by surrounding the relevant {% includeblock %} tag in {% autoescape off %}...{% endautoescape %}.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xfrw-hxr5-ghqf

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-xfrw-hxr5-ghqf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32681

Advisory: Cross-site Scripting in wagtail
IDs: CVE-2021-32681, GHSA-xfrw-hxr5-ghqf
Record: https://patchnext.com/advisories/cve-2021-32681 (revision 3, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wagtail 2.13.2, 2.12.5, 2.11.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI wagtail: affected < 2.11.8; >= 2.12, < 2.12.5; >= 2.13, < 2.13.2; fixed in 2.12.5, 2.11.8, 2.13.2

## Suggested inspection (read-only)
- `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wagtail.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xfrw-hxr5-ghqf (OSV record GHSA-xfrw-hxr5-ghqf lists affected ranges: PyPI wagtail >=0 =2.12 =2.13 <2.13.2 (fixed))
- Verified: https://github.com/advisories/GHSA-xfrw-hxr5-ghqf (GitHub-reviewed advisory GHSA-xfrw-hxr5-ghqf lists affected ranges: PyPI wagtail >=0 =2.12 =2.13 <2.13.2)

Commands are suggestions: review each one before running it.

Loading voting…