Cross-Site Request Forgery (CSRF) in FastAPI
CVE-2021-32677GHSA-8h2j-cgx8-6xv7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastapi 0.65.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI fastapi
- Affected
- < 0.65.2
- Fixed in
- 0.65.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8h2j-cgx8-6xv7 lists affected ranges: PyPI fastapi >=0 <0.65.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8h2j-cgx8-6xv7 lists affected ranges: PyPI fastapi >=0 <0.65.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-32677: 0.72% estimated exploitation activity in the next 30 days; percentile 54.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact FastAPI versions lower than 0.65.2 that used cookies for authentication in path operations that received JSON payloads sent by browsers were vulnerable to a Cross-Site Request Forgery (CSRF) attack. In versions lower than 0.65.2, FastAPI would try to read the request payload as JSON even if the content-type header sent was not set to application/json or a compatible JSON media type (e.g. application/geo+json). So, a request with a content type of text/plain containing JSON data would be accepted and the JSON data would be extracted. But requests with content type text/plain are exempt from CORS preflights, for being considered Simple requests. So, the browser would execute them right away including cookies, and the text content could be a JSON string that would be parsed and accepted by the FastAPI application. Patches This is fixed in FastAPI 0.65.2. The request data is now parsed as JSON only if the content-type header is application/json or another JSON compatible media…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8h2j-cgx8-6xv7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8h2j-cgx8-6xv7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32677 Advisory: Cross-Site Request Forgery (CSRF) in FastAPI IDs: CVE-2021-32677, GHSA-8h2j-cgx8-6xv7 Record: https://patchnext.com/advisories/cve-2021-32677 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fastapi 0.65.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI fastapi: affected < 0.65.2; fixed in 0.65.2 ## Suggested inspection (read-only) - `python -m pip show fastapi`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fastapi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8h2j-cgx8-6xv7 (OSV record GHSA-8h2j-cgx8-6xv7 lists affected ranges: PyPI fastapi >=0 <0.65.2 (fixed)) - Verified: https://github.com/advisories/GHSA-8h2j-cgx8-6xv7 (GitHub-reviewed advisory GHSA-8h2j-cgx8-6xv7 lists affected ranges: PyPI fastapi >=0 <0.65.2) Commands are suggestions: review each one before running it.
Loading voting…