Skip to content

← Actionable
High, CVSS 8.7amended

Remote Code Execution via traversal in TAL expressions

CVE-2021-32674GHSA-rpcg-f9q6-2mq6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zope 5.2.1, 4.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI zope

    Affected
    >= 5.0, < 5.2.1< 4.6.1
    Fixed in
    5.2.1, 4.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-32674: 1.59% estimated exploitation activity in the next 30 days; percentile 75.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

This advisory extends the previous advisory at https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36 with additional cases of TAL expression traversal vulnerabilities.

Impact Most Python modules are not available for using in TAL expressions that you can add through-the-web, for example in Zope Page Templates. This restriction avoids file system access, for example via the 'os' module. But some of the untrusted modules are available indirectly through Python modules that are available for direct use. By default, you need to have the Manager role to add or edit Zope Page Templates through the web. Only sites that allow untrusted users to add/edit Zope Page Templates through the web are at risk.

Patches The problem has been fixed in Zope 5.21 and 4.6.1.

Workarounds The workaround is the same as for https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36: A site administrator can restrict adding/editing Zope Page Templates…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  2. Revision 1 · created ·

    Published from osv record GHSA-rpcg-f9q6-2mq6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32674

Advisory: Remote Code Execution via traversal in TAL expressions
IDs: CVE-2021-32674, GHSA-rpcg-f9q6-2mq6
Record: https://patchnext.com/advisories/cve-2021-32674 (revision 2, source checked 25 Oct 2026, 04:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zope 5.2.1, 4.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI zope: affected >= 5.0, < 5.2.1; < 4.6.1; fixed in 5.2.1, 4.6.1

## Suggested inspection (read-only)
- `python -m pip show zope`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zope.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rpcg-f9q6-2mq6 (OSV record GHSA-rpcg-f9q6-2mq6 lists affected ranges: PyPI zope >=5.0 =0 <4.6.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…