Reflected cross-site scripting issue in Datasette
CVE-2021-32670GHSA-xw7c-jx9m-xh5g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (datasette 0.56.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI datasette
- Affected
- < 0.56.1
- Fixed in
- 0.56.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xw7c-jx9m-xh5g lists affected ranges: PyPI datasette >=0 <0.56.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2021-32670: 0.96% estimated exploitation activity in the next 30 days; percentile 61.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The `?_trace=1` debugging feature in Datasette does not correctly escape generated HTML, resulting in a reflected cross-site scripting vulnerability. This vulnerability is particularly relevant if your Datasette installation includes authenticated features using plugins such as datasette-auth-passwords as an attacker could use the vulnerability to access protected data.
Patches Datasette 0.57 and 0.56.1 both include patches for this issue.
Workarounds If you run Datasette behind a proxy you can workaround this issue by rejecting any incoming requests with `?_trace=` or `&_trace=` in their query string parameters.
References - OWASP guide to reflected cross-site scripting - Datasette issue #1360
For more…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-xw7c-jx9m-xh5g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32670 Advisory: Reflected cross-site scripting issue in Datasette IDs: CVE-2021-32670, GHSA-xw7c-jx9m-xh5g Record: https://patchnext.com/advisories/cve-2021-32670 (revision 2, source checked 25 Oct 2026, 04:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: datasette 0.56.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI datasette: affected < 0.56.1; fixed in 0.56.1 ## Suggested inspection (read-only) - `python -m pip show datasette`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on datasette. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xw7c-jx9m-xh5g (OSV record GHSA-xw7c-jx9m-xh5g lists affected ranges: PyPI datasette >=0 <0.56.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…