Skip to content

← Actionable
Medium, CVSS 6.5amended

Path traversal

CVE-2021-32662GHSA-pgf8-28gg-vpr6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/techdocs-common 0.6.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2021-32662: 1.28% estimated exploitation activity in the next 30 days; percentile 70.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A malicious actor could read sensitive files from the environment where TechDocs documentation is built and published by setting a particular path for docsdir in mkdocs.yml. These files would then be available over the TechDocs backend API. This vulnerability is mitigated by the fact that an attacker would need access to modify the mkdocs.yml in the documentation source code, and would also need access to the TechDocs backend API. Patches The vulnerability is patched in the 0.6.3 release of @backstage/techdocs-common. For more information If you have any questions or comments about this advisory: Open an issue in the Backstage repository Visit our chat, linked to in Backstage README

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pgf8-28gg-vpr6

  2. Revision 1 · created ·

    Published from osv record GHSA-pgf8-28gg-vpr6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32662

Advisory: Path traversal
IDs: CVE-2021-32662, GHSA-pgf8-28gg-vpr6
Record: https://patchnext.com/advisories/cve-2021-32662 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/techdocs-common 0.6.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/techdocs-common: affected < 0.6.3; fixed in 0.6.3

## Suggested inspection (read-only)
- `npm ls @backstage/techdocs-common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/techdocs-common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pgf8-28gg-vpr6 (OSV record GHSA-pgf8-28gg-vpr6 lists affected ranges: npm @backstage/techdocs-common >=0 <0.6.3 (fixed))
- Verified: https://github.com/advisories/GHSA-pgf8-28gg-vpr6 (GitHub-reviewed advisory GHSA-pgf8-28gg-vpr6 lists affected ranges: npm @backstage/techdocs-common >=0 <0.6.3)

Commands are suggestions: review each one before running it.

Loading voting…