Script injection
CVE-2021-32661GHSA-gg96-f8wr-p89f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-techdocs 0.9.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @backstage/plugin-techdocs
- Affected
- < 0.9.5
- Fixed in
- 0.9.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gg96-f8wr-p89f lists affected ranges: npm @backstage/plugin-techdocs >=0 <0.9.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gg96-f8wr-p89f lists affected ranges: npm @backstage/plugin-techdocs >=0 <0.9.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-32661: 1.21% estimated exploitation activity in the next 30 days; percentile 68.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A malicious internal actor can potentially upload documentation content with malicious scripts by embedding the script within an object element. This may give access to sensitive data when other users visit that same documentation page. The ability to upload malicious content may be limited by internal code review processes, unless the chosen TechDocs deployment method is to use an object store and the actor has access to upload files directly to that store. Patches The vulnerability is patched in the 0.9.5 release of @backstage/plugin-techdocs. For more information If you have any questions or comments about this advisory: Open an issue in the Backstage repository Visit our chat, linked to in Backstage README
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gg96-f8wr-p89f
- Revision 1 · created ·
Published from osv record GHSA-gg96-f8wr-p89f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32661 Advisory: Script injection IDs: CVE-2021-32661, GHSA-gg96-f8wr-p89f Record: https://patchnext.com/advisories/cve-2021-32661 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-techdocs 0.9.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/plugin-techdocs: affected < 0.9.5; fixed in 0.9.5 ## Suggested inspection (read-only) - `npm ls @backstage/plugin-techdocs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/plugin-techdocs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gg96-f8wr-p89f (OSV record GHSA-gg96-f8wr-p89f lists affected ranges: npm @backstage/plugin-techdocs >=0 <0.9.5 (fixed)) - Verified: https://github.com/advisories/GHSA-gg96-f8wr-p89f (GitHub-reviewed advisory GHSA-gg96-f8wr-p89f lists affected ranges: npm @backstage/plugin-techdocs >=0 <0.9.5) Commands are suggestions: review each one before running it.
Loading voting…