Skip to content

← Actionable
Medium, CVSS 6.5amended

Automatic room upgrade handling can be used maliciously to bridge a room non-consentually

CVE-2021-32659GHSA-35g4-qx3c-vjhx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-appservice-bridge 2.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2021-32659: 0.94% estimated exploitation activity in the next 30 days; percentile 60.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact If a bridge has room upgrade handling turned on in the configuration (the roomUpgradeOpts key when instantiating a new Bridge instance.), any m.room.tombstone event it encounters will be used to unbridge the current room and bridge into the target room. However, the target room m.room.create event is not checked to verify if the predecessor field contains the previous room. This means that any mailcious admin of a bridged room can repoint the traffic to a different room without the new room being aware. Patches Versions 2.6.1 and greater are patched. Workarounds Disabling the automatic room upgrade handling can be done by removing the roomUpgradeOpts key from the Bridge class options. References The issue is patched by https://github.com/matrix-org/matrix-appservice-bridge/pull/330 For more information] If you have any questions or comments about this advisory, email us at security@matrix.org.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-35g4-qx3c-vjhx

  2. Revision 1 · created ·

    Published from osv record GHSA-35g4-qx3c-vjhx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32659

Advisory: Automatic room upgrade handling can be used maliciously to bridge a room non-consentually
IDs: CVE-2021-32659, GHSA-35g4-qx3c-vjhx
Record: https://patchnext.com/advisories/cve-2021-32659 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: matrix-appservice-bridge 2.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm matrix-appservice-bridge: affected < 2.6.1; fixed in 2.6.1

## Suggested inspection (read-only)
- `npm ls matrix-appservice-bridge --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on matrix-appservice-bridge.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-35g4-qx3c-vjhx (OSV record GHSA-35g4-qx3c-vjhx lists affected ranges: npm matrix-appservice-bridge >=0 <2.6.1 (fixed))
- Verified: https://github.com/advisories/GHSA-35g4-qx3c-vjhx (GitHub-reviewed advisory GHSA-35g4-qx3c-vjhx lists affected ranges: npm matrix-appservice-bridge >=0 <2.6.1)

Commands are suggestions: review each one before running it.

Loading voting…